Facebook Twitter Youtube Twitch
Results 1 to 8 of 8

Thread: Cash shop error

  1. #1

    Cash shop error

    Is anyone getting the same error like I do accessing the cash shop? I've tried clearing cache and cookies but they didn't help. Also, the game has been pretty unresponsive lately, I couldn't use hp or putting stuff into my inventory sometimes. I'm not sure if it's my internet or cabal itself but I could play guildwars without any problems
    Attached Images Attached Images
    • File Type: jpg 2.jpg (6.2 KB, 8 views)
    • File Type: jpg 1.jpg (11.3 KB, 7 views)
    Last edited by ddnquang; 07-03-2015 at 04:40 AM.

  2. #2
    Shadow Titanium Tonberry's Avatar
    Join Date
    Sep 2013
    any time that happens, try using a different browser. sometimes google chrome does that to me, so i just hop on internet explorer.

  3. #3
    I tried both chrome and firefox, same error

  4. #4

  5. #5
    Join Date
    Jan 2014
    Trinidad and Tobago
    internet explorer usually works like ton said , when something goes wrong on other browsers.

  6. #6
    I was able to access the cash shop for a couple of days. Now the error is occurring again and no, it's still not working on internet explorer (no add-on)

  7. #7
    Don't use cash shop
    hi im Peaches
    Quote Originally Posted by IBladE View Post
    Everyone knows a cap bringer is just a person who couldn't get proc bringer.

  8. #8
    Shadow Titanium
    Join Date
    Dec 2013
    use viettel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts